**Open Source**

"Resources that can be used, redistributed or rewritten free of charge. Often software or hardware."

**Electronics**

"Technology which makes use of the controlled motion of electrons through different media."

**Prototype**

"An original form that can serve as a basis or standard for other things."

**Platform**

"Hardware architecture with software framework on which other software can run."
Microcontrollers use inputs and outputs like any computer. Inputs capture information from the user or the environment while outputs do something with the information that has been captured.

An Arduino contains a microchip, which is a very small computer that you can program. You can attach sensors to it that can measure conditions (like how much light there is in the room). It can control how other objects react to those conditions (room gets dark, LED turns on).

A mouse is a common input device for a desktop computer, a monitor is a common output device.

Or it can respond to something as simple as the press of a switch.
Digital information is discrete and finite. All information is described in two states, 1 or 0, on or off.

Analog information is characterized by its continuous nature. It can have an infinite number of possible values.

Inputs and outputs can be **digital** or **analog**. Digital information is binary—it is either true or false. Analog information is continuous, it can hold a range of values.

A switch is a digital input, a sensor is an analog input. The range of an analog sensor is limited by its conversion to digital data.

What's the difference between digital and analog inputs and outputs?

Any object we want to turn on and off and control could be an output. It could be a motor or even a computer.

A switch or a sensor could be an input into the Arduino.

A switch is a digital input, a sensor is an analog input. The range of an analog sensor is limited by its conversion to digital data.

Inputs and outputs can be **digital** or **analog**. Digital information is binary—it is either true or false. Analog information is continuous, it can hold a range of values.
The water analogy is commonly used to explain these terms. Here's one model.

**Voltage (V)** is a measure of electrical potential. It is measured in volts.

**Current (I)** is the amount of flow through a conductive material. It is measured in amperes or amps.

**Resistance (R)** is a material's opposition to the flow of electric current. It is measured in ohms.

Electricity is the flow of energy through a conductive material.

Before we plug in the Arduino, we will review a few terms and principles that have to do with how electricity (and therefore electronics) works.

The speed of flow is determined by voltage.

Resistance increases or decreases flow.

Amount of flow moving through pipes is current.

The water analogy is commonly used to explain these terms. Here's one model.
OHM'S LAW

CURRENT = VOLTAGE/RESISTANCE
\( i = \frac{v}{r} \)

OR

RESISTANCE = VOLTAGE/CURRENT
\( r = \frac{v}{i} \)

OR

VOLTAGE = RESISTANCE * CURRENT
\( v = r \times i \)

There is a relationship between voltage, current, and resistance, discovered by Georg Ohm, a German physicist.

For example, increase the resistance, less flow.

Or increase the potential, more flow.

Now let's look at a simple circuit. Every circuit is a closed loop that has an energy source (battery) and a load (lamp). The load converts the electrical energy of the battery and uses it up. This one has a switch too.

This is a schematic of the same circuit (it represents the circuit using symbols for the electronic components). When the switch is closed, current flows from the power source and lights the lamp.
You'll have to download and install software to program the Arduino. It is available from the URL above free of charge. The Arduino software runs on the Mac OS X, Windows and Linux platforms.

Now that we've reviewed some basics of how electricity works, let's get back to the Arduino.

The Arduino will need power to run. We will need to attach it to a computer to program it.

There are two common types of circuits, Direct Current and Alternating Current. In a DC circuit, the current always flows in one direction. In AC, the current flows in opposite directions in regular cycles. We will only talk about DC circuits here.

Attaching the Arduino to a computer with a USB cable will supply the 5 volts of power we need and allow us to start programming.

Download here:

http://arduino.cc/en/Main/Software

Alternating Current (AC)

Direct Current (DC)
When you have installed the software, connect the Arduino. An LED marked "ON" should light up on the board.

Launch the Arduino software. In the tools menu, select the board you are using (Tools > Board). For example, Arduino Uno.

For instructions on how to install Arduino software on a Mac:


For instructions on how to install on Windows:


For instructions on how to install on Linux:

http://www.arduino.cc/playground/learning/LINUX

Go to the URLs above for detailed instructions on installing the software on these platforms.
int ledPin = 13;

void setup() {
  pinMode(ledPin, OUTPUT);
}

void loop() {
  Serial.println(analogRead(A0));
}

To upload the sketch to the Arduino board, click the UPLOAD button on the strip of buttons at the top of the window. Some messages will appear in the bottom of the window, finally DONE UPLOADING.

The Arduino IDE allows you to write Sketches, or programs and upload them to the Arduino board. Open the BLINK example in the File menu. File > Examples > 1.Basics > Blink.

The LED at pin 13 on the Arduino starts blinking.
void setup() {
    // initialize the digital pin as an output.
    // Pin 13 has LED connected on most Arduino boards
    pinMode(13, OUTPUT);
}

void loop() {
    digitalWrite(13, HIGH);   // set the LED on
    delay(1000);              // wait for a second
    digitalWrite(13, LOW);    // set the LED off
    delay(1000);              // wait for a second
}

A sketch, like a program written in any language, is a set of instructions for the computer. If we look closely at the Blink sketch, we see there are 2 major parts, setup and loop.

HTTP://ARDUINO.CC/EN/REFERENCE/HOMEPAGE

Check out the Arduino website for the Arduino Reference Guide and many other resources to learn the language.

For now, let’s look at this simple script line by line & see what each line does.
When current flows through a LED (Light Emitting Diode) in the right direction, it lights up. We'll attach an LED to the breadboard, then to the Arduino so we can control it with code.

We will connect power and ground from the Arduino board to the vertically connected strips on the left and right with 22 gauge wire. Other components can be attached to the holes in the middle and to power and ground as needed.

How do we control objects that are not on the Arduino board? We will connect the Arduino to a Solderless Breadboard. This will allow us to quickly set up and test circuits.

This breadboard has 2 rows of holes running down the left and right side, and 5 rows of holes on either side of a middle indentation. The side rows are connected vertically, each row of 5 holes in the middle are connected horizontally.
the LED blinks on for half a second, then blinks off for half a second, over and over again.

Click verify on the menu to check your code. If there aren’t any errors, click upload to put your program on the Arduino.

```java
void setup() {
  pinMode(2, OUTPUT);
}

void loop() {
  digitalWrite(2, HIGH);
  delay(500);
  digitalWrite(2, LOW);
  delay(500);
}
```

In setup, we set pin 2 to be an output. In loop, first we set pin 2 high which lights the LED. Delay pauses 500 milliseconds, or half a second. When pin 2 is set low, the LED goes off, we pause another half second.

The anode is connected to pin 2 on the Arduino through a 220 ohm resistor. The cathode is connected to ground. Pins 2 through 13 can be configured as digital inputs or outputs. Click new button to start a sketch.

Click verify on the menu to check your code. If there aren’t any errors, click upload to put your program on the Arduino.

The LED blinks on for half a second, then blinks off for half a second, over and over again.
Next we will add a switch, a digital input, so we can turn the LED off and on.

Next we’ll write the code. In setup, we declare pin 2 an output and pin 4 an input. In loop, we use an if statement, if we read pin 4 as high, we set the LED pin to high, otherwise we set the LED pin to low, turning it off.

```cpp
void setup() {
  pinMode(2, OUTPUT);
  pinMode(4, INPUT);
}

void loop() {
  if(digitalRead(4)) {
    digitalWrite(2, HIGH);
  } else {
    digitalWrite(2, LOW);
  }
}
```

Next we’ll write the code. In setup, we declare pin 2 an output and pin 4 an input. In loop, we use an if statement, if we read pin 4 as high, we set the LED pin to high, otherwise we set the LED pin to low, turning it off.

Connect one end of a momentary switch to pin 4 on the Arduino, with a 10k resistor connected to ground attached to the same end. Attach the other end to power. We will leave the LED attached to the same pin.

The LED lights when the switch is held down.
A potentiometer, or pot, is a variable resistor. The amount of resistance changes as it is turned, increasing or decreasing depending on which direction it is turned.

Now we will set up an analog input. We'll use a potentiometer.

Attach the middle pin on the potentiometer to analog pin A0. Attach one end of the pot to power, the other to ground.

First we will look at the range of values we get by turning the pot using the Serial Monitor. In our code, we initialize the serial object in setup, setting a baud rate of 9600. In loop, we read the value from analog pin A0 and print it to the serial object using the println function.

After you have uploaded the script to the Arduino, click the Serial Monitor button in order to see the values as you turn the pot. A window will open, and you will see values ranging from 0 to 1024 as the pot is turned.
The brightness of the LED changes, ranging from completely off to very bright as you turn the pot.

```cpp
int sensorValue = 0;

void setup() {
    pinMode(3, OUTPUT);
}

void loop() {
    sensorValue = analogRead(A0);
    analogWrite(3, sensorValue/4);
}
```

First we create a variable to store the value of the pot. In setup we make pin 3 an output. In loop, we store the value we have read from pin A0 in our variable. Then we write the value to pin 3, our LED pin. We have to divide the variable by 4, so we will have a range of values from 0 to 255, or a byte.

We’ll use Pulse Width Modulation (PWM). This is a method of simulating an analog value by manipulating the voltage, turning it on and off at different rates, or duty cycles. You can use PWM with pins 3, 5, 6, 9, 10, and 11.

Let’s use the changing values we receive from the pot as a dimmer to control an LED. Attach the anode through a resistor to the board at pin 3, cathode to ground.

The brightness of the LED changes, ranging from completely off to very bright as you turn the pot.
That's it!
This is a very brief intro. In the next panels, there are links and other resources. Check them all out, you'll find lots more!

Links

Software

- Software Download
- Language Reference

Supplies

- Sparkfun Electronics
  - http://www.sparkfun.com/
- Adafruit Industries
  - http://adafruit.com/
- Maker Shed
  - http://www.makershed.com/
- Jameco Electronics
  - http://www.jameco.com/

Tutorials

- Arduino Site Tutorials
- Lady Ada
  - http://www.ladyada.net/learn/arduino/
- Instructables

Books

- Getting Started with Arduino by Massimo Banzi
- Making Things Talk: Using Sensors, Networks, and Arduino to See, Hear, and Feel Your World by Tom Igoe
- Physical Computing: Sensing and Controlling the Physical World with Computers by Dan O'Sullivan & Tom Igoe
- Arduino Cookbook by Michael Margolis

All text and drawings by Jody Culkin
For more, check out jodyculkin.com

Special thanks to Tom Igoe, Marianne Petit, Calvin Reid, the faculty and staff of the Interactive Telecommunications Program at NYU, particularly Dan O'Sullivan, Danny Rozin and Red Burns. Thanks to Cindy Karasek, Chris Stein, Sarah Teitler, Kathy Goncharov & Zannah Marsh.

Many, many thanks to the Arduino team for bringing us this robust and flexible open source platform.

And thanks to the lively, active and ever growing Arduino community.

Introduction to Arduino by Jody Culkin is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License.